Only part of content being imported

Home Forums TurboCSV Support Only part of content being imported

This topic contains 2 replies, has 2 voices, and was last updated by  istudy 4 years, 6 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #11683

    istudy
    Participant

    Hi, me again :-s

    I have a fresh issue and would appreciate your help.

    I’m sending you my CSV file via email. As you will see, I have a column names “SEO Description”, under which there is the text:


    “Have a blast. Explanations, examples and resources to help you learn this English idiom. iStudyEnglishOnline makes it easy to learn English, free.”

    However, when I import, only part of this text is inserted into the SEO Description field (which I have set up as a custom field). This is what displays:

    “Have a blast. Explanations”

     There is a second issue, which, to be honest, I’m not sure is to do with the plugin, my theme or something else. I’ll put it here just in case. You will see that I have another column named “Table”. Here I have some code (using the Easytable plugin shortcodes) that turns into a table when published in a blog. If I take that code and publish it independently (not using TurboCSV), it works fine. However, when I import the code into the post using Turbo, the formatting of the table goes wrong. The strange thing is, if I click “edit” on the post and then “update” without actually changing anything, the formatting of the table fixes itself. I have published an example here. As you will see, the table format is not right. However, to fix it, I have to edit the post and update. Not sure that’s happening there.

     

    Appreciate your support up until now. Hopefully you can help me get to the bottom of these issues, because I’m eager to start using this plugin 🙂

     

    #11684

    Chris
    Keymaster

    Hi,

    For the first question: since you’re importing a “CSV” file, commas are field separators.  Have a look at the documentation about escaping commas.

    For the second, I’m not familiar with the table plugin.  It sounds like maybe it’s doing something when the post is published, since you said it sorts itself out when published manually?

    You could explain to the author that it’s not working when you’ve created your posts using wp_insert_post() – he’ll know what that means, and that’s how TurboCSV creates the posts.

    #11685

    istudy
    Participant

    Thank you! Simple as that 🙂

     

     

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.