Date Import not working / Memory Issue

Home Forums TurboCSV Support Date Import not working / Memory Issue

This topic contains 2 replies, has 2 voices, and was last updated by  istudy 4 years, 4 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #11676

    istudy
    Participant

    Hi,

    I have everything set up just how I want it and am almost ready to do a big bulk upload to my site: istudyenglishonline.com

    However, the only thing I can’t seem to get to work is the post date import. I’ve set a date column in my CSV and have mapped it in the settings. However, this setting is ignored and the date of the import is used instead. It may be worth mentioning that I’m using custom post types, not the WordPress default Post. Is there anything that can be done?

    On a separate issue (should I start a new thread for this?), your plugin tells me that my WordPress memory is low. I have found documentation online to increase this. My question is, do you know if this is sensible? Why does WP limit this in the first place? Sorry, I’m a bit of a novice with this.

    Thanks in advance!

    #11677

    Chris
    Keymaster

    Hi,

    Please send a few lines from your input file (chrisvrichardson@wphostreviews.com).

    What happens when you import the dates to a standard ‘post’ type?  Same issue?

    For the memory: I think it’s sensible to increase the memory if it’s low.  The limit is usually set by your hosting service ( in the php.ini file or elsewhere – you can ask your host).  It’s sometimes set very low.

    When WordPress runs, it request more memory if the host setting is too low.  See the codex entry about WP_MEMORY_LIMIT:

    http://codex.wordpress.org/Editing_wp-config.php

    However, WordPress only requests enough memory to run itself.   As you add plugins or custom themes, the requested amount may be too small.  Imports also consume a small amount for each record imported, which is TurboCSV warns you.

    #11680

    istudy
    Participant

    Thanks for the support over email. As you correctly pointed out, I was uploading the posts as drafts and WP was unable to assign a past date to draft posts. When uploading posts as published, everything works as it should.

    Thanks!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.